Issues loading Getty Images library
Incident Report for Joomag, Inc.
Resolved
The issue is resolved
Posted over 1 year ago. May 02, 2017 - 11:28 PDT
Identified
The issue has been identified and we're working on a solution.
Posted over 1 year ago. May 02, 2017 - 09:58 PDT
Investigating
Some of our customers have been reporting issues with loading of Getty Images library in Crater Editor. We're currently investigating the issue.
Posted over 1 year ago. May 02, 2017 - 07:41 PDT