Issues with Joomag Mailing Services

Incident Report for Joomag, Inc.

Resolved

The issue is resolved
Posted Apr 21, 2022 - 16:28 UTC

Investigating

We're experiencing issues with our mailing services. We're doing our best to restore the functionality. This message will be updated as soon as there is news.
Posted Apr 21, 2022 - 12:08 UTC
This incident affected: Joomag Publishing Cloud and Joomag Mailing Services.