Major outage on Joomag Mailing
Incident Report for Joomag, Inc.
Resolved
The issue is resolved. We're monitoring the system
Posted Oct 22, 2022 - 11:10 PDT
Investigating
We're having a major outage on Joomag Mailing. We're investigating the issue.
Posted Oct 22, 2022 - 09:24 PDT
This incident affected: Joomag Mailing Services.